This project is read-only.

Transition Service unable to update PBI Status.

Aug 2, 2012 at 8:22 PM

  I finally have the Aggregation service and Transition service running on TFS 2010 on Windows Server 2008 R2. The aggregation service seems to be running fine, but the Transition service is throwing an error. 

ScrumForTeamSystem.EventService.TransitionService.SyncAllProcessor - Error Message: Synchronise work item '419' failed.ErrorMsg: There is a problem on the server. Contact your Team Foundation Server administrator.There is a problem on the server. Contact your Team Foundation Server administrator.Error in the application. ---> Error in the application.

  Since there is no error number and Google has let me down on this one, does anyone have an idea why this error is happening? Work item 419 is a PBI with 2 SBTs linked to it. The hours are aggregating up fine, but he PBI status is unchanged even when I SyncAll.

  I would doubt that it's a permissions issue since the aggregation service is updating fine, but I can't be sure at this point. This error is happening for all PBIs (not just #419). Is there a second level of error logging or some way to get more info on this error?

Thanks in advance,
Chris 

Aug 10, 2012 at 8:29 AM

You should be able to get some logging from the TFS application tier. You may need to turn on tracing at the server level by modifying the web.config file.

Aug 14, 2012 at 3:54 PM

Thanks for the suggestion. Today I was setting up the trace output as detailed in the link you sent, and before I had the trace working, I checked the TFS server and what do you know? The integration service started working on 8/9! I don't know what changed on 8/9, but it's working now, so I'm happy! Thanks again for the help.

Chris